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Welcome to Decision Advisor® Menus and Options 

Decision Advisor is a program with an extraordinarily rich set of features. Decision Advisor 
Menus and Options is a brief introduction into the menus and options that implement these 
features.  

There are two companion documents. The first, Quick Start for Decision Advisor, focuses on the 
mechanics of entering and processing information in Decision Advisor. The second, Introduction 
to Decision Advisor, shows how Decision Advisor supports designing, building and analyzing 
business models. 
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Menus: Influence Diagram Tab 

Each window, tab, dialog box in Decision Advisor has its own set of menus and options. The 
most important menus are those on the Influence Diagram tab of the main window of Decision 
Advisor.  

File Menu: The choices in the File menu are mostly standard 
Windows entries.  Some entries to be noted are: 

• Revert to Saved reopens the file, discarding changes made since 
the last “Save.”  This is very useful when you want to experiment.  

• Print requires a PostScript printer. Many printers use a proprietary 
print driver (such as PCL), but PostScript (PS) drivers are often 
also available.  For occasional printing without a PostScript 
enabled printer, use Edit/Copy to copy the screen to the 
clipboard, Paste it into another application and print from there.  

• There are two options for Exporting the influence diagram: as a 
picture (a metafile with .wmf extension) or as a document (in .rtf 
format) describing the content of the diagram. 

 

Edit Menu: The choices in the Edit menu are similar to standard 
Windows entries 

• Undo negates the previous operation of Undo, Cut, Paste, or 
Delete. 

• Cut, Copy, Paste, Delete operate on selected nodes.  Nodes 
can be selected by clicking on them, and nodes can be added to 
the selection by Shift-Click.  Nodes can also be selected by 
clicking on a blank area of the screen and dragging out a 
rectangle to include the desired nodes. 

• Nodes can also be selected by Select All or by Invert Selection 
(which selects the complement of the original selection.) 

 

Node Menu: The choices in the Node menu apply to selected nodes. 

• Open, Rename, and Format open the edit box for selected 
nodes.  You can also get to this edit box by double-clicking on 
the node in the diagram. 

o It is very important to define the units in the Name & Info 
tab of the editor.  The Time Series editor, for example, 
can not find existing nodes unless the appropriate units 
have been defined for the node. 

• Color allows you set the color of a selected set of nodes.  You 
can color individual nodes from the Format tab of the edit box. 
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View Menu: The View menu contains a number of options that either 
affect the display or that open dialog boxes important to the analysis.  

• Node Visibility shows or hides nodes. When a node is hidden, 
it is “behind” one of the visible nodes, which acquires a 
“shadow.” “Direct predecessors” are nodes that are at the foot 
of an arrow leading into the selected node, and “all 
predecessors” are all the nodes that lead into the node via a 
succession of arrows. 

• Error Summary produces a report of the diagram and its 
readiness for evaluation. 

• Project Description produces a dialog box in which you can 
enter a detailed description of the project. 

• System Preferences opens a dialog box in which a number of 
variables can be set.  The value of these variables will be used 
in any new file you open.  Note the small double arrows at both 
sides of the bottom of the dialog box – clicking on these scrolls 
to unseen tabs that were “off to the side” of the box. 

• Global Variables defines variables used in the analysis. (See 
below.) 

• Units defines the units ($, €, widgets, teapots) that are available 
in the analysis. (See below.) 

 

Analyze Menu: The Analyze menu contains the choices that perform 
the principal tasks involved in creating and evaluating a model. 

• Coach Diagram opens the coach (see Quick Start for Decision 
Advisor). Many users use the coach to develop the framework of 
the analysis and then use the palette on the left of the screen to 
add specific detail to finish the model. (See below.) 

• Create Spreadsheet creates an Excel spreadsheet and adds a 
tab at the bottom called Spreadsheet.  If you are using the 
coach, this spreadsheet will automatically be incorporated into 
the analysis procedure. 

• Deterministic Sensitivity uses the Excel spreadsheet to 
calculate the “tornado,” which appears in a tab labeled 
Deterministic Sensitivity. You will be able to choose the value 
measure for the tornado, the base case value for each variable, 
and whether it should be included in the tornado calculation. 
(The most common approach is to accept Decision Advisor’s 
suggestions and click Run.)  

o Menus in the Deterministic Sensitivity tab enable you 
to customize the displays and to export the displays to 
other programs. 
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o Tabs appear on the right side of the screen, enabling you 
to see Deterministic Sensitivity results for the different 
value measures. 

• Probabilistic Analysis uses the results of Deterministic 
Sensitivity to select the most important uncertainties and use 
them in calculating probabilistic results, which appear in two new 
tabs: Cumulative Probability and R&D Project Summary. You 
will be able to customize the probabilistic analysis, but the most 
common approach is to accept Decision Advisor’s suggestions.  

o Tabs appear on the right side of the screen, enabling you 
to see results for different value measures. 

o If you use Edit / Copy in one Cumulative Distribution 
tab and then Paste into another, the two distributions will 
be shown on the same graph. 

• Decision Tree creates a tab with the decision tree in it. 

o When the cursor is over a node, it will turn into an X. 
Clicking and dragging left or right can reorder the nodes 
in the tree. 

Transform menu: The Transform menu is principally used by 
experienced decision analysts. 

• Collapse Diagram removes nodes such as time series and 
formulas from the screen because they are now incorporated 
into the Excel spreadsheet and the compiled model. What 
remains are the nodes describing uncertainty and several 
residual nodes. 

• Probabilistic Inference enables you to manipulate arrows 
among selected nodes and to calculate distributions associated 
with nodes.  Double-click on a node to see the distribution which 
might be generated by one of these operations. 

Help menu: The Help menu contains information to help the Decision 
Advisor User. 

• Overview is a document that orients the user on the purpose 
and use of Decision Advisor. 

• Quick Start Guide helps the new user in the mechanical 
process of using the program.  

• Toolbars and Menus is this overview of Decision Advisors 
menu structure. 

• About Decision Advisor provides information on the version 
and on SmartOrg. 
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Icon Bar 

 

 

The icon bar provides shortcuts to many of the functions provided in the menu of the Influence 
Diagram tab. Going from left to right (the associated icons should be obvious): 

• File menu: New File, Open File, Save File 

• Edit Menu: Cut, Copy, Paste, Delete, Undo 

• View Menu: Node Visibility (Hide/Show), Error Summary, Global Variables, Units 

• Analyze Menu: Coach Diagram, Create Spreadsheet, Deterministic Sensitivity, 
Probabilistic Analysis 
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Palette 

Palette: On the left hand side of the screen is a palette of the nodes 
that can appear in an influence diagram. You can click on one of these 
icons and drag it onto the screen, thus producing a blank node.  You 
can either create the whole diagram manually by dragging nodes to the 
screen and editing them, or you can drag nodes onto a screen created 
by the coach process.  

o Arrows are created by dragging one node in the diagram 
on top of the other.  When one node is dragged over 
another, the image changes from a moved node to a line 
between the nodes. Releasing the mouse restores the 
first node to its original position and draws an arrow 
between the two nodes 

o Arrows can be removed by right-clicking on the head of 
the arrow and choosing Delete.  Arrows can also be 
removed by selecting two nodes and then selecting 
Delete Arrow from the Edit menu. 

o Right-clicking on a node allows you to access the Name 
& Info and Format tabs of the node edit box.  In 
addition, a Diagnosis option is enabled for nodes that 
have problems or that are incompletely specified.  

• Range is the most common of the nodes, allowing you to input 
the estimated Low/Base/High values for the 10/50/90 percentiles 
of the distribution. Double-click on the blank node after you have 
dragged it onto the screen and enter the name, units, and other 
data.  Click the Range tab at the bottom of the window to enter 
range values. 

o Note that you can change the type of a node by clicking 
the radio button on the Name & Info tab of the edit box 
for the node. 

• Distribution is an uncertainty node that allows you to create 
branches in a tree and assign values and probabilities to these 
branches.   

o In the Edit menu of the Distribution tab for these nodes 
is an Outcomes choice that opens an editor for defining 
the branches.  

o When the cursor is over the node circle in the 
Distribution tab, it turns into an X. Right-clicking at this 
point brings up options to Cut, Copy, or Paste the node 
or to edit Outcomes.  

• Decision creates a node that has branches similar to a 
Distribution node (no probabilities) that will function as a 
decision node in the analysis. 
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• Time Series creates a node that will become a series of 
columns (one column for each year) in the spreadsheet. The 
Time Series node is exceedingly flexible. The editor can create 
new nodes, find parameters in existing nodes or globals, etc. 

• Constant creates a node with one branch. 

• Formula creates a node that performs calculations.  At the top 
left of the window is a list of variables that can be used in the 
calculation because they are “direct predecessors” (at foot of 
arrow leading into the node). At the top middle are global 
variables. At the top right are Excel-like formulas that can be 
used in the calculation. 

o Double-clicking on a name in any of the top sections 
enters the name into the formula area at the bottom.  
This operation avoids problems in typing names (which 
are node names modified so that they can be used as 
Excel range names). 

o Syntax is identical to Excel syntax. 

o Decimal numbers must be preceded by a zero – 
Decision Advisor will not recognize .8 as a number, but 
will accept 0.8. Making an error of this type can lead to 
baffling “syntax error” messages. 

o Syntax for special functions (COLUMN_MIN, 
COLUMN_MAX, CONSTANT_UNTIL, CONVOLVE, 
TS_INDEX) is found in the Edit menu of the Formula edit 
box.  

o At the bottom of the Predecessor list at the top left is the 
name of the node itself.  This can be used only by the 
special TS_INDEX function. 

• Spreadsheet is used only by experienced analysts. This node 
functions like a formula except that it uses a spreadsheet to do 
calculations. Most users rely on the Coach to set up the 
spreadsheets to be used in the analysis 

• Value creates the value node on the spreadsheet.  Most users 
rely on the Coach to set up the value function to be used in the 
analysis. 
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Important Dialog and Input Boxes 

Decision advisor has a large number of dialog and input boxes.  Most of them are self-
explanatory.  Two, however, deserve special attention: the windows produced by the Global 
Variables and Units selections in the View menu. 

Global Variables: This window creates variables that are used in the 
analysis. Click on a variable on the left, and its definition will appear on 
the right – you can then edit it and Replace it.  Or you can Add or 
Delete variables. 

• This Year is used as the first year in the spreadsheet.  Final 
Year is 1 year beyond the final year in the spreadsheet. Launch 
Year is the year the Commercial Contribution begins. All must 
have the units “single of calendar year.” 

o There are other alternatives for Launch Year, such as 
creating a node on the spreadsheet. 

• Tax Rate and Discount Rate are used in calculating the NPV of 
Cash Flow in the spreadsheet.  Both have the units “single of 
decimal fraction.” 

• YR is a time series of calendar years from This Year to Final 
Year – 1.  This time series can be used in formulas. 

• The Type dropdown lets you define a number of functions such 
as Depreciation schedules, Terminal Value calculations, 
Working Capital calculations, and the like. 

 

 

 

 

 

Units: This window creates the units that will appear in the node edit 
window and in the coach dialogs. 

• Units can be added and deleted from the system. 

• Checking the Monetary Unit Label box lets the Coach know 
that this is an appropriate candidate for certain financial 
parameters. 

• When the Coach creates formulas, it will adjust the formulas to 
take into account the Magnitudes. 

o When you are creating your own formulas manually, you 
must make sure the units and magnitudes are correct on 
your own! 
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Legal Notes 

 

Decision Advisor® is a registered trademark and Project Navigator™ and Portfolio Navigator™ 
are trademarks of SmartOrg, Inc. 

Excel is a trademark of Microsoft Corporation. 
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